---
title: 上传中
slug: studio-guide-ch/WAsIdmw1XzVaO-Y-u_JdW
docTags: 
createdAt: 2024-09-02T08:34:13.133Z
---

:::hint{type="success"}
**👍&#x20;**&#x4E3A;了帮助您理解指南，页面底部附有一个视频。
观看视频和指南将使您更容易跟随！
:::



在从 Blender 转移到 Unity 之前，您需要做的第一件事是清理您的对象、蒙版和骨架。以下是如何组织它们。

1. 转换 Creator Base Set 对象的对象属性。
2. 解除任何蒙版。
3. 删除不必要的骨骼。
4. 最后，您需要将所有元素排列在一个平坦的层次结构中。



## 步骤 1：设置变换

如果您查看 Creator Base Set 对象属性，您会注意到旋转值并未完全归零，缩放值也未设置为 1。这是因为 Blender 和 FBX 文件在缩放参考和世界轴方面存在差异。

- Blender 使用 M 作为尺寸单位，而 FBX 使用 CM。
- Blender 使用 Z 轴指向上下，而 FBX 使用 Y 轴指向上下。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-CxUACtC1aN5bJTgDvApUW-20240904-102334.png)



1. 选择项目对象后，点击对象 > 父对象 > 清除并保留变换。这将移除任何先前应用的设置。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-LJ15qcRAMfN0YEz10XLFO-20240904-102334.png)



2\. 接下来，点击对象 > 应用 > 所有变换，将当前状态设为默认。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-381GX59HX1-v2xBvxtVHd-20240904-102334.png)



3\. 从视口右上角的选项菜单中选择原点。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-DsZf54oHg1LvoB1Supe10-20240904-102334.png)



4\. 我们需要使用缩放工具将大小更改为0.01。使用**Ctrl键**来微调到小数位。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-n0jedGBeeJ0vkQbK91p-9-20240904-102334.png)



:::hint{type="danger"}
**❗️  注意**这个数字只能使用缩放工具更改，不能直接在设置窗口中输入。
:::



5\. 使用旋转工具在X轴上旋转90度，与步骤4相同。

6\. 在视口右上角的选项菜单中取消选中“Origins”。



## 步骤2：隔离面具

当Unity导入文件时，它会寻找名为mask的网格对象。如果找不到，转换过程将无法正常工作。

1. 选择面具对象，在修改器设置中找到现有的修改器并使用X按钮删除它。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-g-QfZh53FTRnCdP-5VdKE-20240904-102334.png)



2\. 选择面具对象，按下对象 > 父级 > 清除并保留变换。这将把面具与骨架分离。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-gKCRTD0wQcZm3xsZUfYQ8-20240904-102334.png)



## 步骤3：删除不必要的骨架

当你从Blender导出FBX文件时，所有骨骼都会包含权重信息。为了避免在此过程中出现任何容量问题，请删除任何未使用的骨架。

1. 选择Creator Base Set骨架并进入编辑模式。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-qANyDwYXag2JqHO2AN7jH-20240904-102334.png)



2\. 切换到线框视图模式并删除未用于该项目的任何骨骼。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-AzDA_AydOhSEXqFq2Y4j2-20240904-102335.png)



## 步骤 4：关闭层次结构

在导出到FBX文件之前，我们需要确保我们导出的3个对象之间没有任何层次结构。在上一步中，我们取消了面具和骨架的链接，但最好再检查一遍。

1. 选择项目对象并在对象属性中查找关系，以确保没有任何内容连接到父对象。如果有，请点击对象 > 父对象 > 清除并保留变换以断开连接。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-_W093SvTOc7kU4P0_64rS-20240904-102335.png)



2\. 对遮罩对象执行相同操作。



## 步骤 5：导出为 FBX

为了在 Unity 中导入项目，您需要将三个对象 - 项目对象、遮罩对象和骨架 - 导出到一个单一的 FBX 文件中。

1. 选择项目对象、遮罩对象和骨架，然后选择文件 > 导出 > FBX。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-x7DNLYjT2GQ0W3ZyyMiPg-20240904-102335.png)



2\. 在弹出的窗口中，勾选“选定对象”复选框，以确保只提取选定的对象。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-SSFDrj245kFZ7S6Nl71jr-20240904-102335.png)



3\. 在底部的骨架选项卡上，关闭“添加叶骨”和“烘焙动画”选项。

::Image[]{src="https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-XwTZMghWYC16oCSuZ2xDw-20240904-102335.png" size="52" width="358" height="266" position="center" showCaption="false"}



4\. 给它命名并点击“导出”按钮。



## ZEPETO Studio Unity 项目

:::hint{type="danger"}
**❗️  注意**
确保你已安装最新的[Zepeto Unity 项目](docId\:w07ZGd_b89-W3m8FKgcIb)文件和 Unity 2020.3.9。
:::



1. 打开 Unity Hub 并点击“打开”。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-EbiaNHE3F9QWVQletiXft-20240904-102335.png)



2\. 打开 Zepeto Unity 项目文件。此时，选择文件夹以打开其包含的所有文件。



## 简要介绍 Unity

- 当你打开Unity时，你会看到中心的场景视图。这是你进行大部分编辑的地方。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-c8VZnFkqg0kJUqAUD4Z5W-20240904-102335.png)



- 在左边，你可以看到文件的层次结构。这是你可以看到场景中包含的所有对象的地方。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-FgMEY1Uy14P3Q9oQAWKjF-20240904-102335.png)



- 在左下角是项目工具栏。这是你可以看到项目文件中包含的所有对象的地方。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-SNcox5ORv4Av9aRvs407f-20240904-102335.png)



- 右边是检查器面板。在这里你可以查看所选对象的属性。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-AaN1UWZ8xiGN5AIunQd8i-20240904-102335.png)



- 场景视图顶部是游戏标签。游戏标签允许你根据游戏摄像机查看和测试对象。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-4ve7N52fnA9UsUEQbcmek-20240904-102335.png)



## 步骤6：导入FBX

1. 首先，在下面的项目面板中找到Playground并双击打开它。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-QZPY49ExA6cgTaBKvo2Ie-20240904-102335.png)



2\. 打开文件窗口，找到我们之前从Blender中提取的FBX文件，并将其拖入项目面板。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-c_AEO9Se6YU7n5wXHulPq-20240904-102335.png)



3\. 在项目面板中，点击 + > 文件夹按钮创建一个新文件夹。将文件夹命名为项目名称。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-tChhFL0TDiHIL5XdHUNLb-20240904-102335.png)



4\. 将FBX文件拖入新创建的文件夹中，并双击文件夹将其打开。



## 步骤 7：导入纹理并创建材质

1. 与导入FBX文件一样，打开包含您之前处理过的纹理文件的文件夹，并将其拖到Unity内部的项目面板中。
2. 在项目面板中，点击 + > 材质 按钮以创建新材质。将材质命名为与您的项目相同的名称。
3. 您需要将Unity默认材质更改为ZEPETO使用的着色器。ZEPETO的项目是专门为在ZEPETO应用中良好运行而制作的着色器。

- 这些着色器被命名为ZEPETO，并包含在Zepeto Unity项目文件中。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-xqvjCfC-MxDO7oDaaA8wf-20240904-102335.png)

4\. 在ZEPETO着色器组中，选择您需要的着色器类型。



## 步骤 8：将材质分配给项目

1. 选择您的项目并查看检查器面板。将项目面板中的材质拖动以连接它们，然后点击底部的应用以应用它们。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-8f97XTmyK3GnqvOSO5CUr-20240904-102335.png)



## STEP 9 \:Convert to ZEPETO Style

1. 选择你的FBX文件并右键点击。选择Zepeto Studio > 转换为ZEPETO风格。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-BUIjBmHuCqXK9xo-4sSGx-20240904-102335.png)



2\. 第一步将创建一个与你创建的项目相同的文件。在Unity中，这称为Prefab。

:::hint{type="danger"}
**❗️  注意**
如果Prefab没有生成，Unity可能会有导出项目的问题。如果项目命名为mask，也会导致问题，因此请确保在上一步中检查并更改名称。
:::



## STEP 10 : Test the item

一旦您的物品预制件创建完成，您可以测试您的物品。

1. 在Unity中打开Playground，点击顶部的播放按钮。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-XCXRLjPTF7if1x27sSQpo-20240904-102335.png)



2\. 屏幕会切换，您会看到ZEPETO的头像在中心。 从右侧的层次面板中选择Loader，在检查器面板中，您会看到ZEPETO提供的不同物品类别列表。 选择您创建的物品类别并检查。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-dwDFd-O1wYGZEFfV6s2u9-20240904-102335.png)



3\. 从底部的项目面板中拖动一个预制件并将其放入检查器面板中类别旁边的框中。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-OGyZXDzY8gEPbUva7bIyb-20240904-102335.png)



4\. 利用变形按钮测试你的物品在不同姿势下的效果。



:::hint{type="danger"}
**❗️  注意**
如果在此过程中发现你的物品有任何问题，你需要返回Blender进行修复。
:::



## 步骤 11：导出为 .zepeto 文件

一旦你完成了物品的测试，你需要将其导出为 .zepeto 文件。

1. 首先，导出过程在播放模式下不起作用，所以请按顶部的播放按钮退出播放模式。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-NJiXviK3-AXMzxbORG4Hl-20240904-102335.png)



2\. 选择您的物品预制件，右键单击，然后选择 Zepeto Studio > 导出为 .zepeto。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-oKzQPBe2ekkakecoX31cJ-20240904-102335.png)



恭喜，您现在有一个 .zepeto 文件，可以上传到 ZEPETO Studio。

:::hint{type="info"}
**📘&#x20;**&#x8BF7;参考以下指南。\[[输入详情](docId\:Mw_1tww7C2QIPD51NCXYZ)]
:::



::embed[[https://www.youtube.com/watch?v=WJQPuMUKLOU](https://www.youtube.com/watch?v=WJQPuMUKLOU)]{url="https://www.youtube.com/watch?v=WJQPuMUKLOU"}

