---
title: アップロード中
slug: studio-guide-ja/fbiInzX9-RA6TD2b0TygQ
docTags: 
createdAt: 2024-09-02T08:34:13.133Z
---

:::hint{type="success"}
**👍&#x20;**&#x30AC;イドを理解するのに役立つように、ページの下部にビデオが添付されています。
ガイドと一緒にビデオを見ることで、より簡単に進めることができます！
:::



BlenderからUnityに移行する前に、最初に行うべきことはオブジェクト、マスク、アーマチュアを整理することです。以下にその方法を示します。

1. Creator Base Setオブジェクトのオブジェクトプロパティを変換します。
2. マスクを解除します。
3. 不要なボーンを削除します。
4. 最後に、すべての要素をフラットな階層に配置する必要があります。



## ステップ1：トランスフォームの設定

Creator Base Setオブジェクトのプロパティを見ると、回転値が完全にゼロになっておらず、スケール値が1に設定されていないことに気付くでしょう。これは、BlenderとFBXファイルの間でスケールの基準とワールド軸に違いがあるためです。

- Blenderはサイズ単位としてMを使用し、FBXはCMを使用します。
- BlenderはZ軸を上下に使用し、FBXはY軸を上下に使用します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-CxUACtC1aN5bJTgDvApUW-20240904-102334.png)



1. アイテムオブジェクトを選択した状態で、オブジェクト > 親 > 変換を保持してクリアをクリックします。これにより、以前に適用された設定が削除されます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-LJ15qcRAMfN0YEz10XLFO-20240904-102334.png)



2\. 次に、オブジェクト > 適用 > すべての変換をクリックして、現在の状態をデフォルトにします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-381GX59HX1-v2xBvxtVHd-20240904-102334.png)



3\. ビューポートの右上隅にあるオプションメニューから「オリジン」を選択します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-DsZf54oHg1LvoB1Supe10-20240904-102334.png)



4\. サイズを0.01に変更するには、スケールツールを使用する必要があります。 **Ctrlキー** を使用して小数点以下の桁を微調整します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-n0jedGBeeJ0vkQbK91p-9-20240904-102334.png)



:::hint{type="danger"}
**❗️  注意**この数値はスケールツールを使用してのみ変更でき、設定ウィンドウに直接入力することはできません。
:::



5\. ステップ4と同様に、X軸で90度回転させるには、回転ツールを使用します。

6\. ビューポートの右上隅にあるオプションメニューから「Origins」のチェックを外します。



## ステップ2：マスクを分離する

Unityがファイルをインポートするとき、マスクという名前のメッシュオブジェクトを探します。見つからない場合、変換プロセスは正しく機能しません。

1. マスクオブジェクトを選択し、モディファイア設定で既存のモディファイアを見つけ、Xボタンで削除します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-g-QfZh53FTRnCdP-5VdKE-20240904-102334.png)



2\. マスクオブジェクトを選択した状態で、オブジェクト > 親 > クリアして変換を保持を押します。これにより、マスクがアーマチュアから分離されます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-gKCRTD0wQcZm3xsZUfYQ8-20240904-102334.png)



## ステップ3：不要なアーマチュアを削除する

BlenderからFBXファイルをエクスポートする際、すべてのボーンにはウェイト情報が含まれます。このプロセス中に発生する可能性のある容量の問題を避けるために、未使用のスケルトンを削除してください。

1. Creator Base Setのスケルトンを選択し、編集モードに入ります。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-qANyDwYXag2JqHO2AN7jH-20240904-102334.png)



2\. ワイヤーフレームビューに切り替え、アイテムに使用されていないボーンを削除します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-AzDA_AydOhSEXqFq2Y4j2-20240904-102335.png)



## STEP 4 : 階層をオフにする

FBXファイルにエクスポートする前に、エクスポートする3つのオブジェクトの間に階層がないことを確認する必要があります。前のステップでマスクとスケルトンのリンクを解除しましたが、再確認することをお勧めします。

1. アイテムオブジェクトを選択し、オブジェクトプロパティでリレーションを確認して、親に何も接続されていないことを確認します。接続されている場合は、オブジェクト > 親 > 変換を保持してクリアをクリックして切断します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-_W093SvTOc7kU4P0_64rS-20240904-102335.png)



2\. マスクオブジェクトについても同様に行います。



## ステップ 5 : FBX へのエクスポート

アイテムを Unity にインポートするには、アイテムオブジェクト、マスクオブジェクト、およびアーマチュアの3つのオブジェクトを単一の FBX ファイルにエクスポートする必要があります。

1. アイテムオブジェクト、マスクオブジェクト、およびアーマチュアを選択し、ファイル > エクスポート > FBX を選択します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-x7DNLYjT2GQ0W3ZyyMiPg-20240904-102335.png)



2\. ポップアップするウィンドウで、選択されたオブジェクトのチェックボックスをオンにして、選択されたオブジェクトのみが抽出されるようにします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-SSFDrj245kFZ7S6Nl71jr-20240904-102335.png)



3\. 下部のアーマチュアタブで、リーフボーンの追加とアニメーションのベイクオプションをオフにします。

::Image[]{src="https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-XwTZMghWYC16oCSuZ2xDw-20240904-102335.png" size="52" width="358" height="266" position="center" showCaption="false"}



4\. 名前を付けて、エクスポートボタンをクリックします。



## ZEPETO Studio Unity Project

:::hint{type="danger"}
**❗️  注意**
最新の[Zepeto Unity Project](docId\:JtaxlvCdxMVk9xGqMaex1)ファイルとUnity 2020.3.9がインストールされていることを確認してください。
:::



1. Unity Hubを開き、\[Open]をクリックします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-EbiaNHE3F9QWVQletiXft-20240904-102335.png)



2\. Zepeto Unity Projectファイルを開きます。この時点で、フォルダーを選択してその中に含まれるすべてのファイルを開きます。



## Unity in a nutshell

- Unityを開くと、中央にシーンビューが表示されます。ここでほとんどの編集を行います。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-c8VZnFkqg0kJUqAUD4Z5W-20240904-102335.png)



- 左側にはファイルの階層が表示されます。ここでシーンに含まれるすべてのオブジェクトを確認できます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-FgMEY1Uy14P3Q9oQAWKjF-20240904-102335.png)



- 左下にはプロジェクトツールバーがあります。ここでプロジェクトファイルに含まれるすべてのオブジェクトを確認できます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-SNcox5ORv4Av9aRvs407f-20240904-102335.png)



- 右側にはインスペクターパネルがあります。ここでは、選択したオブジェクトのプロパティを表示できます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-AaN1UWZ8xiGN5AIunQd8i-20240904-102335.png)



- シーンビューの上部にはゲームタブがあります。ゲームタブでは、ゲームカメラに合わせてオブジェクトを表示およびテストできます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-4ve7N52fnA9UsUEQbcmek-20240904-102335.png)



## ステップ6: FBXをインポートする

1. まず、下のプロジェクトパネルでプレイグラウンドを見つけて、ダブルクリックして開きます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-QZPY49ExA6cgTaBKvo2Ie-20240904-102335.png)



2\. ファイルウィンドウを開いて、先ほどBlenderから抽出したFBXファイルを見つけ、プロジェクトパネルにドラッグします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-c_AEO9Se6YU7n5wXHulPq-20240904-102335.png)



3\. プロジェクトパネル内で、+ > フォルダボタンをクリックして新しいフォルダを作成します。フォルダの名前をアイテムの名前にします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-tChhFL0TDiHIL5XdHUNLb-20240904-102335.png)



4\. FBXファイルを新しく作成したフォルダにドラッグし、フォルダをダブルクリックして開きます。



## STEP 7 : テクスチャをインポートしてマテリアルを作成する

1. FBXファイルをインポートするのと同様に、以前に作業したテクスチャファイルが含まれているフォルダーを開き、それをUnityのプロジェクトパネルにドラッグします。
2. プロジェクトパネル内で、+ > マテリアルボタンをクリックして新しいマテリアルを作成します。マテリアルの名前をアイテムの名前と同じにします。
3. UnityのデフォルトのマテリアルをZEPETOが使用するシェーダーに変更する必要があります。ZEPETOのアイテムは、ZEPETOアプリでうまく動作するように作られた特殊なシェーダーです。

- これらのシェーダーはZEPETOと呼ばれ、Zepeto Unity Projectファイルに含まれています。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-xqvjCfC-MxDO7oDaaA8wf-20240904-102335.png)

4\. ZEPETOシェーダーグループ内で、必要なシェーダーのタイプを選択します。



## STEP 8 : アイテムにマテリアルを割り当てる

1. アイテムを選択し、インスペクターパネルを表示します。プロジェクトパネル内のマテリアルをドラッグして接続し、下部の適用をクリックして適用します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-8f97XTmyK3GnqvOSO5CUr-20240904-102335.png)



## STEP 9 \:Convert to ZEPETO Style

1. FBXファイルを選択して右クリックします。Zepeto Studio > Convert to ZEPETO styleを選択します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-BUIjBmHuCqXK9xo-4sSGx-20240904-102335.png)



2\. ステップ1は、作成したアイテムと同一のファイルを作成します。Unityでは、これをPrefabと呼びます。

:::hint{type="danger"}
**❗️  注意**
Prefabが生成されない場合、Unityはエクスポートされたアイテムに問題がある可能性があります。また、アイテムの名前がmaskである場合にも問題が発生する可能性があるため、前のステップで名前を確認して変更することを確認してください。
:::



## STEP 10 : Test the item

アイテムプレハブが作成されたら、アイテムをテストできます。

1. UnityでPlaygroundを開いた状態で、上部の再生ボタンをクリックします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-XCXRLjPTF7if1x27sSQpo-20240904-102335.png)



2\. 画面が切り替わり、中央にZEPETOのアバターが表示されます。右側のヒエラルキーパネルからLoaderを選択し、インスペクターパネルでZEPETOが提供するさまざまなアイテムカテゴリのリストが表示されます。作成したアイテムのカテゴリを選択して確認します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-dwDFd-O1wYGZEFfV6s2u9-20240904-102335.png)



3\. 下部のプロジェクトパネルからプレハブをドラッグし、インスペクターパネルのカテゴリの横のボックスにドロップします。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-OGyZXDzY8gEPbUva7bIyb-20240904-102335.png)



4\. Deformボタンを使用して、アイテムをさまざまなポーズでテストします。



:::hint{type="danger"}
**❗️  注意**
このプロセス中にアイテムに何か問題があることに気付いた場合は、Blenderに戻って修正する必要があります。
:::



## STEP 11 : .zepetoファイルにエクスポート

アイテムのテストが完了したら、.zepetoファイルにエクスポートする必要があります。

1. まず、エクスポートプロセスはプレイモードでは機能しないため、上部の再生ボタンを押してプレイモードを終了します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-NJiXviK3-AXMzxbORG4Hl-20240904-102335.png)



2\. アイテムのプレハブを選択し、右クリックして Zepeto Studio > Export as .zepeto を選択します。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-oKzQPBe2ekkakecoX31cJ-20240904-102335.png)



おめでとうございます。これで、ZEPETO Studio にアップロードできる .zepeto ファイルができました。

:::hint{type="info"}
**📘&#x20;**&#x4EE5;下のガイドを参照してください。 \[[詳細を入力](docId\:EgNXbu3rj_DB3H930PiAE)]
:::



::embed[[https://www.youtube.com/watch?v=WJQPuMUKLOU](https://www.youtube.com/watch?v=WJQPuMUKLOU)]{url="https://www.youtube.com/watch?v=WJQPuMUKLOU"}

