---
title: 5. ワールドを公開する
slug: world-sdk-guide-ja/5
docTags: 
createdAt: 2025-04-22T05:23:00.797Z
---

# 公開前に確認すべき5つのステップ

:::::WorkflowBlock
::::WorkflowBlockItem
## Build Settingsを確認する

Unityプロジェクトで Menu → File → Build Settings を開いてください。

Scenes in Build に、ワールド内で必要なすべてのSceneが登録されていることを確認してください。

ワールド起動時に最初に実行されるSceneは、リストの最上部に配置する必要があります。

::Image[]{src="https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-OIz2gz2tXfR-T0f7fAAMK-20240904-102429.png" size="68" width="630" height="732" position="center" showCaption="false"}

:::hint{type="danger"}
**❗️重要**
Sceneが正しく登録されていないと、QRテストやパブリッシュ時にワールドが正常に表示されない可能性があります。
:::


::::

::::WorkflowBlockItem
## Project Settings > Qualityを確認する

Edit > Project Settings > Quality に移動し、以下の設定を確認してください。

PC、iOS、Android それぞれに対して、適切な品質レベルを設定してください。

以下は ZEPETO 推奨のデフォルト設定です：

::Image[]{src="https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-1Xy3eNSrP39G0yXJUxcZd-20240904-102429.png" size="70" width="762" height="836" position="center" showCaption="false"}

:::hint{type="success"}
👍 品質設定のポイント

- 高品質に設定すると、端末が発熱しやすくなります
- 以下の設定は変更できません：
  - Skin Weight：4 Bones
  - Vsync Count：Don’t sync
- シャドウ（影）の設定は、クリエイターがUnityで設定した内容がそのまま反映されます
- 影が表示されない場合、次の点を確認してください：
- iOS・Androidの品質レベルが一致しているか
- Shadowsの初期設定は「Disable Shadow」になっているため、有効になっているかを確認
- Light setting や Mesh Renderer のシャドウ設定に問題がないか
- Shadow Distance の初期値は 0.0001 に設定されています。適切な値に調整してください
:::


::::

::::WorkflowBlockItem
## Project Settings > Qualityでアンチエイリアス設定を行う

Anti-aliasing を設定することで、キャラクターやオブジェクトの輪郭を滑らかに表示することができます。

::Image[]{src="https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-4MwKhwVRqL-nMOO6kbDYc-20240904-102429.png" size="70" width="800" height="753" position="center" showCaption="false"}

各設定によって、グラフィック表示に以下のような違いがあります：

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-xrHhByXGBReLZTBp28Qmr-20240904-102429.png)

:::hint{type="danger"}
**❗️注意**
Post Processing の Anti-aliasing を使用している場合は、Quality Settings の Anti-aliasing を 無効（Disable） にしてください。
:::

:::hint{type="info"}
**📘&#x20;**[Unity公式Anti-aliasingのドキュメント](https://docs.unity3d.com/2018.4/Documentation/Manual/PostProcessing-Antialiasing.html)
:::


::::

::::WorkflowBlockItem
## Project Settings > Player にて Graphics API を設定する

以下の手順に従って、各プラットフォームごとに設定してください。

### 4-1. PC

1. Unity > Project Settings > Player > Settings for PC, Mac & Linux Standalone を開きます
2. Graphics APIs for Mac に Metal を追加します
3. Metal をリストの最上部にドラッグします
4. 再起動を求めるポップアップが表示されたら、Restart Editor をクリックしてください

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-dOE0QJS_7IJeJ2sRkUlC--20240904-102429.png)

### 4-2. iOS

1. Unity > Project Settings > Player > iOS タブ を選択します
2. Graphics APIs にて、Metal をリストの最上部にドラッグします
3. 設定変更後、エディターの再起動が必要な場合は、Restart Editor を選択してください

Metalがすでに設定済みであれば、上記のように表示されます。

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-CWLFo9ZNXi3Yrigz07cIS-20240904-102429.png)

### 4-3. Android

1. Unity > Project Settings > Player > Android タブ を選択します
2. Graphics APIs にて、OpenGLES3 を一番上にドラッグします
3. ポップアップが出たら、Restart Editor を選択して再起動してください

![](https://api.archbee.com/api/optimize/fCt3n1oCa8rgNJ8fw9I2N-mgqCNEMywZZhsKJySCNNt-20240904-102429.png)

:::hint{type="danger"}
**❗️注意**
Graphics API の設定が正しく行われていないと、シェーダーが正常に表示されない可能性があります。
:::


::::

:::WorkflowBlockItem
## Target Platforms を「All」に設定する

Unity エディター中央のメニューで \[▼] をクリックします。

表示されるメニューから Target Platforms > All を選択してください。

::Image[]{src="https://images.archbee.com/fCt3n1oCa8rgNJ8fw9I2N-Lu-IIVHVNp--OGgNtKgVP-20240904-102429.png?format=webp" size="78" width="422" height="281" position="center" showCaption="false"}
:::
:::::



# いよいよワールドを公開しましょう！

:::::WorkflowBlock
:::WorkflowBlockItem
## &#x20;Publish ボタンをクリック

1\. 完成したワールドのファイルを作成するには、画面中央の \[Publish] ボタンをクリックしてください。

![](https://images.archbee.com/fCt3n1oCa8rgNJ8fw9I2N-jw_CdYK4tvCMBRAmBz0Bt-20240904-102429.png?format=webp)

- ワールドの ID を所有しているアカウントのみが Publish を行えます
- ZEPETO サービスにワールドがリンクされていない場合、アップロードは失敗します



2\. ポップアップの \[Upload] をクリックすると、生成された .zepetopackage ファイルが自動的に ZEPETO Studio にアップロードされます。

3\. \[Cancel] をクリックした場合は、.zepetopackage ファイルを ZEPETO Studio にドラッグ＆ドロップして手動で登録することもできます。

::Image[]{src="https://images.archbee.com/fCt3n1oCa8rgNJ8fw9I2N-ttXrO6Rj1wVyw5_B1zs0k-20240904-102429.png?format=webp" size="70" width="387" height="153" position="center" showCaption="false"}


:::

::::WorkflowBlockItem
## ZEPETO Studio にワールドファイルを登録する

ZEPETO Studio で \[新しいファイルをアップロード] ボタンをクリックし、.zepetopackage ファイルをアップロードするか、ドラッグ＆ドロップでアップロードしてください。

:::hint{type="danger"}
**⚠️ 注意**
以下の条件を満たしたファイルのみアップロード可能です

- **ファイル形式**：.zepetopackage
- **ファイルサイズ**：1024MB 未満B
:::



![](https://images.archbee.com/fCt3n1oCa8rgNJ8fw9I2N-vp6O5cQc8NPGOcmQSGh3U-20240904-102429.png?format=webp)



👍 アップロード済みのファイルを削除または変更したい場合は、画面右側の その他オプション ボタンをクリックしてください。

![](https://images.archbee.com/fCt3n1oCa8rgNJ8fw9I2N-xcbwwBUFJjl8UQUcws3OZ-20240904-102425.jpg?format=webp)
::::
:::::



***

