5. ワールドを公開する
公開前に確認すべき5つのステップ
Build Settingsを確認する
Unityプロジェクトで Menu → File → Build Settings を開いてください。
Scenes in Build に、ワールド内で必要なすべてのSceneが登録されていることを確認してください。
ワールド起動時に最初に実行されるSceneは、リストの最上部に配置する必要があります。

❗️重要 Sceneが正しく登録されていないと、QRテストやパブリッシュ時にワールドが正常に表示されない可能性があります。
Project Settings > Qualityを確認する
Edit > Project Settings > Quality に移動し、以下の設定を確認してください。
PC、iOS、Android それぞれに対して、適切な品質レベルを設定してください。
以下は ZEPETO 推奨のデフォルト設定です:

👍 品質設定のポイント
- 高品質に設定すると、端末が発熱しやすくなります
- 以下の設定は変更できません:
- Skin Weight:4 Bones
- Vsync Count:Don’t sync
- シャドウ(影)の設定は、クリエイターがUnityで設定した内容がそのまま反映されます
- 影が表示されない場合、次の点を確認してください:
- iOS・Androidの品質レベルが一致しているか
- Shadowsの初期設定は「Disable Shadow」になっているため、有効になっているかを確認
- Light setting や Mesh Renderer のシャドウ設定に問題がないか
- Shadow Distance の初期値は 0.0001 に設定されています。適切な値に調整してください
Project Settings > Qualityでアンチエイリアス設定を行う
Anti-aliasing を設定することで、キャラクターやオブジェクトの輪郭を滑らかに表示することができます。

各設定によって、グラフィック表示に以下のような違いがあります:

❗️注意 Post Processing の Anti-aliasing を使用している場合は、Quality Settings の Anti-aliasing を 無効(Disable) にしてください。
Project Settings > Player にて Graphics API を設定する
以下の手順に従って、各プラットフォームごとに設定してください。
4-1. PC
- Unity > Project Settings > Player > Settings for PC, Mac & Linux Standalone を開きます
- Graphics APIs for Mac に Metal を追加します
- Metal をリストの最上部にドラッグします
- 再起動を求めるポップアップが表示されたら、Restart Editor をクリックしてください

4-2. iOS
- Unity > Project Settings > Player > iOS タブ を選択します
- Graphics APIs にて、Metal をリストの最上部にドラッグします
- 設定変更後、エディターの再起動が必要な場合は、Restart Editor を選択してください
Metalがすでに設定済みであれば、上記のように表示されます。

4-3. Android
- Unity > Project Settings > Player > Android タブ を選択します
- Graphics APIs にて、OpenGLES3 を一番上にドラッグします
- ポップアップが出たら、Restart Editor を選択して再起動してください

❗️注意 Graphics API の設定が正しく行われていないと、シェーダーが正常に表示されない可能性があります。
Target Platforms を「All」に設定する
Unity エディター中央のメニューで [▼] をクリックします。
表示されるメニューから Target Platforms > All を選択してください。

いよいよワールドを公開しましょう!
Publish ボタンをクリック
1. 完成したワールドのファイルを作成するには、画面中央の [Publish] ボタンをクリックしてください。

- ワールドの ID を所有しているアカウントのみが Publish を行えます
- ZEPETO サービスにワールドがリンクされていない場合、アップロードは失敗します
2. ポップアップの [Upload] をクリックすると、生成された .zepetopackage ファイルが自動的に ZEPETO Studio にアップロードされます。
3. [Cancel] をクリックした場合は、.zepetopackage ファイルを ZEPETO Studio にドラッグ&ドロップして手動で登録することもできます。

ZEPETO Studio にワールドファイルを登録する
ZEPETO Studio で [新しいファイルをアップロード] ボタンをクリックし、.zepetopackage ファイルをアップロードするか、ドラッグ&ドロップでアップロードしてください。
⚠️ 注意 以下の条件を満たしたファイルのみアップロード可能です
- ファイル形式:.zepetopackage
- ファイルサイズ:1024MB 未満B

👍 アップロード済みのファイルを削除または変更したい場合は、画面右側の その他オプション ボタンをクリックしてください。
